Jump to content

Search the Community

Showing results for tags 'lightmap'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Public Forums
    • Announcements
    • General Chatter
    • Tournaments
    • Mapping forum
    • UI Scripting
    • Trading
    • Support
    • Bugs
    • Silver Screen

Found 9 results

  1. I wrote a steam guide on how to publish a map without a lightmap, bypassing the in-game publish restrictions. Here's a link to it: http://steamcommunity.com/sharedfiles/filedetails/?id=892726203
  2. Lightmap build

    I know it is not the newest change, but what happened with the lightmap build process? Now it is faster alright (guess it handles more complex geometry better), but IMO completely lost its classy global illuminated look. Previously on geometrically simple maps it was so cool to run lm_build and watch how suddenly everything looked professionally lit. Is this something you are working on, or this is considered final for now?
  3. playing without lightmap

    Hey, I love reflex and the way it looks, but im always been attracted by simple and clear graphics in game, so i was wadering... is it possible to play with r_lm_clear without having the annoying message "lightmap invalid, please rebuild"? ty in advance
  4. Lightmap bug

    So I built lightmap and... http://images.akamai.steamusercontent.com/ugc/436076195944883477/861DF677E57DE8E0D55F011512D0AED07295FC1C/ I've tried building the lightmap multiple times, and it keeps happening I've tried increasing/decreasing graphics too. I've been working hard on this map and I'm worried if there is no way to fix it :'( pls halp
  5. If the ivy clips through a wall it makes the whole thing glow, same with the other new stuff added. Ok I think it has to do with them being upside-down.
  6. Regarding Light Maps

    I have been getting some strange glitches and other issues with lightmaps. I am ready to release a map, but the lightmap doesnt seem to save for me. I build the lightmap, it saves to the map folder, but when I load up the map at another time, the lightmap isnt loaded. Am I supposed to save the map before I build the lightmap, or after? Also, when entering the "r_lm_build" command, should I enter it as "r_lm_build mapname"? Ive tried both without success. I have gotten a few lightmaps to save permanently, but I'm not sure what I'm doing wrong the times it doesnt save. A very strange glitch which I have not come across on forums is when I build a lightmap, then the textures on the walls glitch out and seem to be covered in a strange texture that looks just like the r_lm_debug_show screen, but just blurry. This issue is usually resolved by re-starting the game. Any Ideas? The visual glitch might be related AMD drivers, I have a HD7850.
  7. Dealing with Light Leaks?

    From what I can see, there are two kinds of light leaks: 1) Enviromental light that leaks through thin walls and floors. Looks disgusting but can be fixed by reducing the lightmap texel size. (r_lm_texel_size) (Default is 16) 2) Light emitted from effects such as the teleporter rings. Also looks disgusting and from what I've seen can't be fixed by reducing the texel size. I'm trying to figure out how to get rid of both regardless of texel size, but especially 2). I've tried using the Nolight material but I can't figure out how to use it properly so that the players don't see it.
  8. [fixed] Low fps without lightmaps

    In addition to maxfps problems I figured out that I have this another problem with performance. If I play map without lightmap I get low fps, after i build lightmap fps boosts to normal stable 90. Got 580 gtx so shouldnt really be hardware related. Its definately a bug? [edit] Did some further testing and it seems than rather of low fps its just the same stutter i got with highres with no fps limit. This isnt as critical though. Basicly my is fps jumping +100 even if its limited to 90 and just like with that stutter this issue doesnt happen in low res, only in high res modes
  9. Hi, whenever I pick a map like cpm3 a message pops up in the center of the screen saying : Lightmap invalid , please rebuild. Does someone knows how to "rebuild"? Thanks.
×