KovaaK

KovaaK's compilation HUD

45 posts in this topic

Some of the timers seem to have been broken by the update. Mega is locked at 30s held. Green armors seems to do the same, though I don't have them enabled atm.

Bonuspunkt found a few of the issues related to items not showing up in the right spot when they are up.  I just went through and fixed some of them in my copy (updated zip in first post).  Also I fixed some trueStack number issues with the team and enemy team stack numbers.  (dp2hudrip.lua and KovEnemyTeamInfo.lua)

Share this post


Link to post
Share on other sites

Its a very great pack, I really like it. But the only problem I had was the 4:3 resolution compatibility. So I adjusted everything to fit and look nice, and here is how it looks like... (My resolution is 1024x768) Btw I'd really like to see the green armor tracker button to be re added. (I think its useful for newer players who don't really know the maps, like me) I tried to replace the apheleon_TimerTimeline.lua with that one from the link you left but that one is kinda broken, I mean the icons are getting stuck on the timeline end and start, and the bars for available pickups are not showing... But I don't think this is your problem, so nvm. c: If you like my edit and ofc if you want I can edit the offsets in kovhud.cfg for the 4:3 "version". Cheers! :D

2015-10-25_00001.jpg

KovaaK likes this

Share this post


Link to post
Share on other sites

Its a very great pack, I really like it. But the only problem I had was the 4:3 resolution compatibility. So I adjusted everything to fit and look nice, and here is how it looks like... (My resolution is 1024x768) Btw I'd really like to see the green armor tracker button to be re added. (I think its useful for newer players who don't really know the maps, like me) I tried to replace the apheleon_TimerTimeline.lua with that one from the link you left but that one is kinda broken, I mean the icons are getting stuck on the timeline end and start, and the bars for available pickups are not showing... But I don't think this is your problem, so nvm. c: If you like my edit and ofc if you want I can edit the offsets in kovhud.cfg for the 4:3 "version". Cheers! :D

​Looks very nice, man.  I'm sure someone would appreciate it if you tossed your version of the GUI locations to a file on dropbox or something on pastebin.

To get the green armors back on the timeline, open up apheleon_TimerTimeline.lua.  There are two lines (should be line 228 and 285) that look like this:

		if vis ~= nil and pickupTimers[i].type ~= PICKUP_TYPE_ARMOR50 then

Change them to this:

		if vis ~= nil then

 

Share this post


Link to post
Share on other sites

Whats the green marker on the armorbar? It confuses me

​How low your armour has to be to pick up a green. There's also a yellow bar when you have red.

Eldrek and KovaaK like this

Share this post


Link to post
Share on other sites

If anyone else is using this compilation and having issues with the Workshop callvote window not popping up here is a workaround.

Download https://www.dropbox.com/s/2o32b1e372vlnll/MatchPicker.lua?dl=
Make a folder in "\Steam\SteamApps\common\reflexfps\base\internal\ui" called "popups" and then I made another subfolder in that popups folder, you can name it whatever and put the lua file in there.

Basically the problem I encountered was a comparison mismatch for the part that fills in the stars in the star rating in that callvote window which made it not pop up anymore, all this does is work around the comparison by removing the comparison and using a static number. Downside is that now every map shows as 5 star map, but sorting on highest ranked still seems to work so it should be purely a visual thing, more importantly the window keeps popping up now when I want to do a callvote through that (which is far more conveniant than looking up the id's of maps...).

 

The original MatchPicker.lua can be found in "\Steam\SteamApps\common\reflexfps\base\internal.pak" that can be opened with something like 7zip (haven't tried others but I assume WinRAR can probably open it too) and then go to the "internal\ui\popups\" folder in there and you can then open it in a text editor to see the original.

The only change I have made is in line 219 (where the error was).
I changed

nvgFillColor((stars >= star) and colOn or colOff);

  to

nvgFillColor((1) and colOn or colOff);

 

banReflex likes this

Share this post


Link to post
Share on other sites
3 hours ago, NhaMeh said:

If anyone else is using this compilation and having issues with the Workshop callvote window not popping up here is a workaround.

Can confirm, this fixed my issue.

Share this post


Link to post
Share on other sites

After I downloaded the config and followed your steps to the letter, the game seemed to break. I experienced connection issues, and after I decided to get rid of the config (by deleting the file from the SteamApps/reflexfps/base files) the default scoreboard is no longer visible. I cant see how many points I or my opponent has. What the hell happened?

Share this post


Link to post
Share on other sites
59 minutes ago, Tchernobog said:

After I downloaded the config and followed your steps to the letter, the game seemed to break. I experienced connection issues, and after I decided to get rid of the config (by deleting the file from the SteamApps/reflexfps/base files) the default scoreboard is no longer visible. I cant see how many points I or my opponent has. What the hell happened?

Any chance you have any error messages in your console?

Share this post


Link to post
Share on other sites
14 hours ago, KovaaK said:

Any chance you have any error messages in your console?

Seems the only "error message" (quotes b/c idk if it's actually an error message) I could find was "unknown entity type ' '".  The problem may be with my own router, but all my other devices have no connection issues, and any other game I play on my computer is fine too.

EDIT: So I reset my router, did not fix the problem. In fact, I'm having connection issues in all my other games as well. Don't think that the problemis the HUD, so sorry to bother you

Share this post


Link to post
Share on other sites
2 hours ago, Tchernobog said:

EDIT: So I reset my router, did not fix the problem. In fact, I'm having connection issues in all my other games as well. Don't think that the problemis the HUD, so sorry to bother you

No worries.  Good luck with your connection issues.

Share this post


Link to post
Share on other sites

Hi new to Reflex and I find this HUD very cool but when I type in the console "loadconfig kovhud" my current HUD disappears.

I've placed the .cfg fils into the 'base' folder as it is in the 1st post.

Is this HUD up to date and how can I make it work ?

Share this post


Link to post
Share on other sites
2 hours ago, OG BlacKout said:

Hi new to Reflex and I find this HUD very cool but when I type in the console "loadconfig kovhud" my current HUD disappears.

I've placed the .cfg fils into the 'base' folder as it is in the 1st post.

Is this HUD up to date and how can I make it work ?

I haven't updated it for a while.  I figured when the steam workshop support for LUA is added, I'll update things then.

For the time being, is there an error message in your console or anything?  It sounds like the pak file with the hud might not be in the right folder if nothing gets loaded.

Share this post


Link to post
Share on other sites
13 hours ago, KovaaK said:

I haven't updated it for a while.  I figured when the steam workshop support for LUA is added, I'll update things then.

For the time being, is there an error message in your console or anything?  It sounds like the pak file with the hud might not be in the right folder if nothing gets loaded.

Where should I put the .pak file ? I've seen on another topic that it should go into the "base/internal/ui" folder. I don't have the ui folder so I guess I should create it and put it there right?

 

And yes I got an error message that only displays "cannot open kovhud.cfg"

Share this post


Link to post
Share on other sites
2 hours ago, OG BlacKout said:

Where should I put the .pak file ? I've seen on another topic that it should go into the "base/internal/ui" folder. I don't have the ui folder so I guess I should create it and put it there right?

 

And yes I got an error message that only displays "cannot open kovhud.cfg"

kovHUD.pak should be under "base" and kovhud.cfg should be in the same folder as the reflex.exe.  Sorry, I'll try to make that more clear in the original post!

Share this post


Link to post
Share on other sites

Thank you! Works like a charm now :) 

 

The kill feed is really nice to me but the fade time is a bit long. Can I modify that ? If yes how ?

Share this post


Link to post
Share on other sites

That is the original.  Strange - I thought I had it in my list of addons to begin with.  Anyway, meowgli has a bunch of options available for the killfeed in the widgets menu.

Share this post


Link to post
Share on other sites
41 minutes ago, RIKARD said:

Can I download the Accelmeter somewhere else? phgp.tv seems to be down

Bej uploaded to workshop. It should be available as an addon there.

Share this post


Link to post
Share on other sites
10 minutes ago, lolograde said:

Bej uploaded to workshop. It should be available as an addon there.

I found it, thank you very much

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now