Jump to content
Sign in to follow this  
jjjuho

[fixed] Low fps without lightmaps

Recommended Posts

In addition to maxfps problems I figured out that I have this another problem with performance. If I play map without lightmap I get low fps, after i build lightmap fps boosts to normal stable 90. Got 580 gtx so shouldnt really be hardware related.

 

Its definately a bug?

 

[edit]

 

Did some further testing and it seems than rather of low fps its just the same stutter i got with highres with no fps limit. This isnt as critical though. Basicly my is fps jumping +100 even if its limited to 90 and just like with that stutter this issue doesnt happen in low res, only in high res modes

Share this post


Link to post
Share on other sites

As theres no reply's il post few screenshots demonstrating the problem. It seems that fps is hopping over my fps limit (90) and variance between frametimes is way bigger than with lightmap. This only happens with high resolution such as 2560x1440.

 

reflex-without-lightmap.jpg

Share this post


Link to post
Share on other sites

The 580 is a 5 year old card that should play Reflex well on 720p but at 1080p or higher might stutter a bit.  Yeah it's a 580 but look around the forums and you'll see people having issues even with a 660 generation card which should outperform the 580 in a DX11 game.  It has nothing to do with real time lighting vs lightmap but on the limitations of your card.  You have to understand that ANY card will play better with a built lightmap.  So saying that your card performs worse with real time lighting and expecting that not to be the case is odd.  That's the way it works for everyone. 

 

Saying that it "shouldn't be hardware related" is you just hoping that's it not and is a meaningless way to assert your cards ability to do the task at hand.  I recently upgraded to a 750 ti (midrange) and it plays Reflex phenomenally better than my old 660.  My 660 has tons of issues with performance which prompted me to upgrade.  I can play full res on 750 ultra settings especially after the recent netcode update.  I know you don't want to think it's time to upgrade but the game in it's current Alpha build  it's EXTREMELY demanding on any 4, 5, and 6 series card.  Time to upgrade to series 7 at the least.  In the future, developers will try to get those requirements down but as right this second it's still deceptively demanding. It's a hog for sure.

 

In it's current build and engine hogging performance issues the least I would recommend is a 7 series (750) if you want to play full res.  If you have an older card then drop it down to 720p res to play full screen.  It won't look as nice but it will give you better performance by not stressing the gpu as much.  Also read the performance sticky and ensure you read all the tips for getting the most out of performance you can.

 

660 > 580

750 > 660

time to upgrade

 

One thing I've learned about the Reflex graphic engine and graphic card performance is this; what you think your card is capable of and what it's actually capable of are two different things.  Regard the Reflex engine as you would Crysis 4.  It's a hog wild beast of an unoptimized engine right now and it's because developers started off with DX11 as the basis.  They have to downcode everything in the future for DX10 and lower capability cards.  That has yet to happen so until that does there's going to be a lot of people trying to play this game that complain about performance.  It's not an affront to you or your card it's just the nature of the unoptimized state of the current engine. 

 

Nice looking map by the way. :)

Share this post


Link to post
Share on other sites

580 gtx is a beast still, it runs pretty much any game with 2560x1440 and should also run Reflex. If it wouldnt have the horsepower I would just have constant low fps, but rather than I have weird fps stutter.

 

Like you see, the screenshot performing worse I have higher fps. Also why would missing lightmap make game perform worse? Its just a baked texture thats applied over the map? If it doesnt exist performance should rather be better as it doesnt need to be applied. Issue is also extremely weird as it just gets on after some resolution, rather than it would exist on all resolutions.

 

This is some kind of bug for sure, as the other stutter problems are. They have been getting better patch by patch, but still exist and need to be looked into for further improvements

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×