Jump to content
newborn

0.34.2 - Unmeltable steel beams

Recommended Posts

Game
  • Added automatic map rotations
  • Callvote command now supports "rotation <name>" and "nextmap"
  • Added power-ups to racemode (so quad actually spawns in)
  • Added power-up stay to racemode. when you pickup quad, it stays on the ground.
  • Plasma gun is once again projectile based. 
  • Added "reset_vars" command to reset all console vars to their defaults. This is now written to config above vars, just like unbind all is written to config above binds (fixes issues where vars aren't set to defaults (when they should be) when switching between configs.
  • Replaced "r_resolution" command with "r_resolution_windowed" and "r_resolution_fullscreen" commands.
  • Game now ends early if there are not enough players / not enough on team.
  • Added "callvote restart" command
  • Added reconnect command.
  • Tweaked player outlines
  • Team mate outlines now show through walls.
  • Added r_bloom 3. It's faster and looks better but still has some bugs to be squashed.
  • Added cl_weaponcycle command. This controls if nextweapon/lastweapon commands loop through.
  • "weapon X" now only works if you are carrying that weapon. (instead of switching you to burstgun)
  • Increased max chat line length to 256 characters (up from 64)
  • Replay files now contain a header with game info
  • Replay filenames now use player names for 1v1 matches
Server
  • We now have files in base/internal/rotations/*.rotation which allow you to put the server in rotation
  • Added sv_startrotation to define the rotation to start the server with (if not defined, it falls back to sv_startmap/sv_startmode)
  • Added "rotation" console command (dedi only), sets current rotation
  • Added "nextmap" console command (dedi only), steps to next map/mode in rotation
  • Added initial default.rotation
UI
  • Fixed typo in loading screen tip
  • Updated options menu to work with new resolution cvars
  • Options menu will now correctly display the refresh rates available for the resolution you're changing to (as opposed to previously where it would always show the refresh rates available for the current resolution)
  • Added optionalid to colour picker (provided by aliasedfrog)
Scripting
  • Added headers do-not-modify warning headers to all official lua scripts.
  • Updated chatlog.lua to support an input line longer than the window (can scroll forwards/backwards with cursor / multiselect)
  • Updated chatlog.lua to support multi-line chat from other players.
  • Updated Chatlog "Chaingun" -> "Plasma Rifle"
Art
  • Added material: trims/metal_01
  • Added material: concrete/concrete_bunker_02 variant
  • Added material: cinderblock_01_painted_* variants (variety of flavours)
  • Added material: concrete_polished
  • Added materials: concrete_02, concrete_polished
  • Added material: trims/metal_02
  • Added materials: corrugated_sheet_iron, corrugated_plated
  • Added mesh: sheet_iron
  • Added meshes: i beams
  • Updated wall_tube2 (less saturated colour, larger radius, increased intensity)
  • Updated materials/effect files: windows (increased intensities slightly)
  • Fixed wood material not being lightmapped correctly
Fixes
  • When an error occurs playing a replay, the client is now correctly returned to disconnected state (fixes bug where menubar wasn't appearing on bogus menu.rep)
  • "re_speed" is now ignored for menu replay
  • Fixed brush UV rotation tool, now finds correct brush angles.
  • "cl_show_gun 0" now works as it should (doesn't just pull gun down by 100 units :))
  • Removed weapon/power-up drop in racemode (happened when you fell out of world)
  • Fixed bug where sometimes cursor wasn't locking to window bounds in fullscreen mode.
  • Player no longer take 1 tick of lava damage when respawning after dying in lava.

Share this post


Link to post
Share on other sites

Wooohooo no more esc twice every time I alt tab and no more r_resolution 1920 1080 when I alt+enter, plasma oh how I've missed you.. So many minor annoyances in one patch :)

 

Doesn't seem like it saves the resolution settings for when you launch the game again though. I figured out what was wrong.. My fault :) Our eminent demoflex write protecting the game.cfg

Share this post


Link to post
Share on other sites

Unless I previously missed it, it might be noteworthy to mention the new / or renamed maps called:

 

devscene0

devscene1

 

The former we already know, the letter shows off the corrugated metal and windows that let through light and cast shadows.

Share this post


Link to post
Share on other sites

Alot of waited fixed and new stuff, nice! Some observations and thoughs:

 

-You can write longer chat messages, but they don't appear fully on the screen.

-cl_show_gun 0 just makes the gun invisible so with IC it looks like this http://i.imgur.com/XYdH8SG.png?1. I don't know is this intentional, but I prefer how it looks with cl_weapon_offset_x 0 and cl_weapon_offset_z -20 http://i.imgur.com/94qywLA.png

-Bolt is blue, so I think it would be cooler if plasma was purple like in that old movement overview. Also trails of the plasma would be same colour as the plasma.

-Can I stop or silence the menu replay? I like to leave Reflex open between gaming sessions, because for some reason it takes ages to start up for me and I don't want to hear those jumping sounds. I know you can remove the replays folder, but I think there should be command for it.

Share this post


Link to post
Share on other sites

Alot of waited fixed and new stuff, nice! Some observations and thoughs:

 

-You can write longer chat messages, but they don't appear fully on the screen.

-cl_show_gun 0 just makes the gun invisible so with IC it looks like this http://i.imgur.com/XYdH8SG.png?1. I don't know is this intentional, but I prefer how it looks with cl_weapon_offset_x 0 and cl_weapon_offset_z -20 http://i.imgur.com/94qywLA.png

-Bolt is blue, so I think it would be cooler if plasma was purple like in that old movement overview. Also trails of the plasma would be same colour as the plasma.

-Can I stop or silence the menu replay? I like to leave Reflex open between gaming sessions, because for some reason it takes ages to start up for me and I don't want to hear those jumping sounds. I know you can remove the replays folder, but I think there should be command for it.

 

long chat messages appear as multiple lines: http://i.imgur.com/t8BsVt3.jpg what's the issue?

 

you can use g_sound to turn off volume if you want, or just delete the menu.rep file if you really dislike it.

Share this post


Link to post
Share on other sites

long chat messages appear as multiple lines: http://i.imgur.com/t8BsVt3.jpg what's the issue?

 

Doesn't work for me. I can write the long message, but it will be cut when it appears on screen.

 

 

you can use g_sound to turn off volume if you want, or just delete the menu.rep file if you really dislike it.

 

unknow command "g_sound"

 

Yeah it's pretty annoying when you try to browse the web or do something else and you hear all those gaming sounds.

Share this post


Link to post
Share on other sites

2 things:

 

ContentBrowserHack is not functioning properly for me since this patch.

 

I am able to send only 1 texture to Reflex. Attempting to send a second texture, results in nothing being written to the console. I have to manually close and relaunch the browser every time I wish to use a new texture, or manually type the file location parameters.

 

Windowed mode behaves almost as though it were ignoring my video settings. Game reports it is running at over 160 FPS constantly, but it very clearly is only displaying 30-60 FPS (my monitor is a 144 Hz display, and it functions just fine in fulscreen mode.). It feels very laggy/choppy, and it's very frustrating as I use windowed mode during map editing so I can access my other windows efficiently. r_refreshrate 144 does not solve the problem.

Share this post


Link to post
Share on other sites

2 things:

 

ContentBrowserHack is not functioning properly for me since this patch.

 

I am able to send only 1 texture to Reflex. Attempting to send a second texture, results in nothing being written to the console. I have to manually close and relaunch the browser every time I wish to use a new texture, or manually type the file location parameters.

 

Windowed mode behaves almost as though it were ignoring my video settings. Game reports it is running at over 160 FPS constantly, but it very clearly is only displaying 30-60 FPS (my monitor is a 144 Hz display, and it functions just fine in fulscreen mode.). It feels very laggy/choppy, and it's very frustrating as I use windowed mode during map editing so I can access my other windows efficiently. r_refreshrate 144 does not solve the problem.

Can you check your monitor settings to make sure it's actually running at 144hz?

Share this post


Link to post
Share on other sites

2 things:

ContentBrowserHack is not functioning properly for me since this patch.

I am able to send only 1 texture to Reflex. Attempting to send a second texture, results in nothing being written to the console. I have to manually close and relaunch the browser every time I wish to use a new texture, or manually type the file location parameters.

Windowed mode behaves almost as though it were ignoring my video settings. Game reports it is running at over 160 FPS constantly, but it very clearly is only displaying 30-60 FPS (my monitor is a 144 Hz display, and it functions just fine in fulscreen mode.). It feels very laggy/choppy, and it's very frustrating as I use windowed mode during map editing so I can access my other windows efficiently. r_refreshrate 144 does not solve the problem.

i dont have any of that issues

Share this post


Link to post
Share on other sites

I really can't wait to see someone take full advantage of the new assets. They're obviously still pretty limited, but there's enough now that I could see some gorgeous maps if done with the right setting and detail level. (not to say there aren't any pretty maps now, some of the minimalistic stylings this community has produced are phenomenal) The dev scene 1 is kind of neat, and for some reason I really like that new hall in thinktank.

 

I will say that the textures look kind of "pastel"y cartoonish, or what ever. Kind of disappointing. That aesthetic can definitely be very pleasing and successful, but I was hoping for more of a grittier realistic look.

Share this post


Link to post
Share on other sites

Can you check your monitor settings to make sure it's actually running at 144hz?

 

Indeed it is. It's only having this effect within the game window itself. The rest of my programs (where applicable) are correctly displaying at 144.

 

I'd like to note that this system is pretty much brand new, with a fresh install of Windows 7 (fully updated) complete with the latest relevant drivers for my hardware. The game was not behaving this way prior to the patch, so I'm confused as to what the cause is.

Share this post


Link to post
Share on other sites

The game was not behaving this way prior to the patch, so I'm confused as to what the cause is.

Not nearly as confused as we are about this mysterious "running at 200fps but feels like 30fps" bug that comes and goes each release, despite us not touching anything that could cause it.

Share this post


Link to post
Share on other sites

s_volume 0. Shooter doesn't know his own commands.

As for your chat messages, maybe verify your Steam cache and make sure you've got the updated chatlog widget?

 

Didn't work, neither did re-install. I can write long messages, but this is the longest it will be displayed in the screen http://i.imgur.com/DbWXHmN.pngalso you can see that the last B doesn't fully show.

Share this post


Link to post
Share on other sites

It splits to new lines on spaces, so if you've got a word longer than that.. well, it should actually force a new line.

 

Oh man, when I write an actual long sentence, I don't have any problems. I just went to a server to test it and pushed random letters. I'm such a fucking retard. This is actually great, prevents from spamming.

Share this post


Link to post
Share on other sites

Not nearly as confused as we are about this mysterious "running at 200fps but feels like 30fps" bug that comes and goes each release, despite us not touching anything that could cause it.

 

I'd say that's a pretty big exaggeration, the game feels choppy even though it runs at 200fps.. not sure why it feels choppy but it does.. At least when I compare it to ql/wsw/qw/hl

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×