Jump to content
newborn

0.36.3 Point Release

Recommended Posts

Game:

  • No longer play character pain sounds on < 10 damage
  • Tweaked IC hit sound (again)

Bug fixes:

  • Player now removed from editor state on disconnect (fixes bug where you see menu playback in editor mode)
  • Fixed crash dialog interrupting very slow loads (slow loads will be somewhat addressed in .37)
  • Fixed crash bug when the .light file didn't provide all reflection probes
  • Fixed previous optimisations to be DX10 compatible
  • Fixed colour override workflow -- if you override a material & not colour within an effect, the default colour will now come from the new material (instead of the default colour on the effect).

Share this post


Link to post
Share on other sites

When will the new inputlag problem be fixed?

I could play reflex before 36.0 with rather precise mousefeel but now its just horrible because it seems like the requirements lifted quite much since i have everything on low except res and i get the performance what i get. Before 36.0 i didnt even have all on low and had good performance for playing.

Share this post


Link to post
Share on other sites

The input thing just feels worse the less fps you have spessu_sb.. Nothing really changed with that issue just the average fps lowered so it became way more noticeable.. It's still there at 1000fps..

Sorry about yet again voicing this issue.. It's known I know it's just the reason I'm not playing still :)

Edited by Holi
Added last thing

Share this post


Link to post
Share on other sites

The input thing just feels worse the less fps you have spessu_sb.. Nothing really changed with that issue just the average fps lowered so it became way more noticeable.. It's still there at 1000fps..

Sorry about yet again voicing this issue.. It's known I know it's just the reason I'm not playing still :)

​Well the thing is.. i kinda get some 100-125 fps but still the input feels horrid compared to before. And before i believe i got pretty much stable 125.

Share this post


Link to post
Share on other sites

Input is tied to framerate currently. It's a known issue. 

We have a couple of input bugs, one of which is subframe being broken which when fixed will address this issue. 

If you have weak hardware though and aren't running at a stable fast framerate then your experience obviously won't be as good regardless.

Share this post


Link to post
Share on other sites

Input is tied to framerate currently. It's a known issue. 

We have a couple of input bugs, one of which is subframe being broken which when fixed will address this issue. 

If you have weak hardware though and aren't running at a stable fast framerate then your experience obviously won't be as good regardless.

​Well, as i said.. before this otherwise in all ways magnificent patch, i used to have alot more smoother mouse feel and that this input problem only started from 0.36.0

I am using 2x 1gb hd7770 on and off on crossfire because reflex doesn't really like crossfire.. As cpu, i have 8-core fx-8350 4.0GHz. I know my gpu is kinda on the weakerside but i still should be getting a smooth experience atleast when everything set to Low, like how i had relatively good experience performance-wise before 0.36 even when not everything was on Low.

Edited by spessu_sb

Share this post


Link to post
Share on other sites

Your cpu/gpu combo isn't that great for reflex.. It's using a couple of nvidia based technologies that just perform worse on amd hardware.. I had way more erratic framerates on my amd rig when I was running one :(
Hoping stuff can get optimized one way or another but guessing it would take a ton of work for a minority of the playerbase :(

Share this post


Link to post
Share on other sites

​Well, as i said.. before this otherwise in all ways magnificent patch, i used to have alot more smoother mouse feel and that this input problem only started from 0.36.0

I am using 2x 1gb hd7770 on and off on crossfire because reflex doesn't really like crossfire.. As cpu, i have 8-core fx-8350 4.0GHz. I know my gpu is kinda on the weakerside but i still should be getting a smooth experience atleast when everything set to Low, like how i had relatively good experience performance-wise before 0.36 even when not everything was on Low.

​It's most likely performing faster on older box maps still. It simply won't be performing as fast on maps that have visuals added.

Share this post


Link to post
Share on other sites

​It's most likely performing faster on older box maps still. It simply won't be performing as fast on maps that have visuals added.

​I'm still wondering what kinda quality-standard visually you wanna go for ...i guess at some point with MM you'll have somekinda "official" map-pool, so having them look equally good would make sense, wouldn't it?

 

Share this post


Link to post
Share on other sites

​I'm still wondering what kinda quality-standard visually you wanna go for ...i guess at some point with MM you'll have somekinda "official" map-pool, so having them look equally good would make sense, wouldn't it?

 

​That's right, that's the goal eventually. For now I've only done a visual pass on bdm3.

Share this post


Link to post
Share on other sites

​That's right, that's the goal eventually. For now I've only done a visual pass on bdm3.

​Yeah, i know. But i guess you gonna implement some community maps into the official pool as well, won't you? And if the mappers do a...meh job at making them "pretty" .... will you do/rework them?

Edited by FPSports - A. Benz

Share this post


Link to post
Share on other sites

​Yeah, i know. But i guess you gonna implement some community maps into the official pool as well, won't you? And if the mappers do a...meh job at making them "pretty" .... will you do/rework them?

​That's also the plan yes

Share this post


Link to post
Share on other sites

it looks like I cannot join friends on a reflex server anymore via steam. 

connect to ip is ok.

It is only like this since 0.36.2. first time I have this and another friend as well.

is this related to steam or reflex itself?

Share this post


Link to post
Share on other sites

it looks like I cannot join friends on a reflex server anymore via steam. 

connect to ip is ok.

It is only like this since 0.36.2. first time I have this and another friend as well.

is this related to steam or reflex itself?

​Shooter said he'd fix that for 0.37 when I told him about it on IRC

Share this post


Link to post
Share on other sites

​Well the thing is.. i kinda get some 100-125 fps but still the input feels horrid compared to before. And before i believe i got pretty much stable 125.

​seems as good a spot as any to mention/ask this:

ive been playing cpm with 125fps since forever. ive started playing reflex with 250fps(Since thats what my pc can comfortably pull off).

when i put maxfps to 125 in reflex, the game just feels reaaaally bad, has noticable input delay and turning looks very stuttery. im not quite sure if its just the fact that i'm used to 250fps in reflex, that makes 125fps look so bad, or if the game is for some reason not built to run at low framerates. i don't even know how that would make sense, quake also doesnt use motion blur or anything like that afaik, right? so shouldnt it be the same in quake(haven't tried yet tbh)?

Share this post


Link to post
Share on other sites

​seems as good a spot as any to mention/ask this:

ive been playing cpm with 125fps since forever. ive started playing reflex with 250fps(Since thats what my pc can comfortably pull off).

when i put maxfps to 125 in reflex, the game just feels reaaaally bad, has noticable input delay and turning looks very stuttery. im not quite sure if its just the fact that i'm used to 250fps in reflex, that makes 125fps look so bad, or if the game is for some reason not built to run at low framerates. i don't even know how that would make sense, quake also doesnt use motion blur or anything like that afaik, right? so shouldnt it be the same in quake(haven't tried yet tbh)?

​What refreshrate do you play on? I noticed at under 125 fps the game felt really sluggish, at 125 exactly it felt okay but there was lots of tearing (pretty sure its the same in q3 tbh) and at 200+ the tearing gets less noticeable and it looks really smooth. What I also noticed is that if I cap my fps to my refreshrate (75) the game felt the smoothest with an occasional large tear across the screen, instead of all the tiny tears at 125.

Share this post


Link to post
Share on other sites

​seems as good a spot as any to mention/ask this:

ive been playing cpm with 125fps since forever. ive started playing reflex with 250fps(Since thats what my pc can comfortably pull off).

when i put maxfps to 125 in reflex, the game just feels reaaaally bad, has noticable input delay and turning looks very stuttery. im not quite sure if its just the fact that i'm used to 250fps in reflex, that makes 125fps look so bad, or if the game is for some reason not built to run at low framerates. i don't even know how that would make sense, quake also doesnt use motion blur or anything like that afaik, right? so shouldnt it be the same in quake(haven't tried yet tbh)?

​Reminds me a bit of this thread, although it was about previous versions: http://www.reflexfps.net/forums/index.php?/topic/1991-jerkiness-with-certain-values-of-com_maxfps/

(125 was always good for me though, except briefly in version 0.31.0)

Edited by matt_au

Share this post


Link to post
Share on other sites

​Reminds me a bit of this thread, although it was about previous versions: http://www.reflexfps.net/forums/index.php?/topic/1991-jerkiness-with-certain-values-of-com_maxfps/

(125 was always good for me though, except briefly in version 0.31.0)

​ah, haven't seen that. will try later at different values, might be the issue is fixed, who knows.

Share this post


Link to post
Share on other sites

​seems as good a spot as any to mention/ask this:

ive been playing cpm with 125fps since forever. ive started playing reflex with 250fps(Since thats what my pc can comfortably pull off).

when i put maxfps to 125 in reflex, the game just feels reaaaally bad, has noticable input delay and turning looks very stuttery. im not quite sure if its just the fact that i'm used to 250fps in reflex, that makes 125fps look so bad, or if the game is for some reason not built to run at low framerates. i don't even know how that would make sense, quake also doesnt use motion blur or anything like that afaik, right? so shouldnt it be the same in quake(haven't tried yet tbh)?

​The input is currently tied to the framerate, so the lower your framerate is the more input lag you have. At 125fps it's 8ms, at 250fps 4ms, that's why 250fps feels so much better. That will change when cl_input_subframe gets reimplemented properly, which will reduce inputlag to 1ms regardless of framerate.

Share this post


Link to post
Share on other sites

dunno if it happend in 0.36.1, 2 or 3, but the game became kind of unsmooth with 0.36, and i wasn't even sure i wasnt imagining things. but booting it up today, it is back to pre-0.36 smoothness and its awesome. 

also had to build lightmap on bdm3 and it was more than twice as fast than ever befor. what the hell happened there`?

Share this post


Link to post
Share on other sites

​What refreshrate do you play on? I noticed at under 125 fps the game felt really sluggish, at 125 exactly it felt okay but there was lots of tearing (pretty sure its the same in q3 tbh) and at 200+ the tearing gets less noticeable and it looks really smooth. What I also noticed is that if I cap my fps to my refreshrate (75) the game felt the smoothest with an occasional large tear across the screen, instead of all the tiny tears at 125.

​i use 120hz refreshrate. my monitor is also 120hz and strobelight thingied.

Share this post


Link to post
Share on other sites

Hi. 

Merely wanted to add another 'fps went to shit' report post. :] I'm on a i7 extreme & r9 290x setup and the framerate really tanked after 0.36.. went from constant stable 250 to sub-100 drops mid-fights in ffa, with everything on medium and AA and bloom disabled. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×