Jump to content
ok_hand

[0.36.4] Screen tearing/jerky mouse input

Recommended Posts

At first I thought it was just a problem with my eyes or that I was tired or something. But I happened to be looking at one of the old dev textures while turning my camera last night I noticed I'm having severe screen tearing in fullscreen. When I switched to windowed the screen tearing went away completely. Whatever is causing the screen tearing is making my mouse input wank causing it to get all jerky, which I originally thought was just in my head. Mouse input feels much smoother and accurate when in windowed versus fullscreen for me right now, was able to test this in a server with PixelTerrorist.

I don't know if this has anything to do with using 2 monitors or that I have an SLI setup or something, but it's kinda making it hard to play, as windowed is hard for me to play in especially with my current setup. I'd really rather not use vsync, which does remove the tearing, since it usually causes input lag. If I have the FPS locked at 120, which should fix the problem as it does in most games, I still get the screen tearing. I even used DXTory to force-lock the FPS at 120 and not 125 which is what the in-game lock sticks to (even using com_maxfps 120 it still went to 125) and still no dice.

Share this post


Link to post
Share on other sites

At first I thought it was just a problem with my eyes or that I was tired or something. But I happened to be looking at one of the old dev textures while turning my camera last night I noticed I'm having severe screen tearing in fullscreen. When I switched to windowed the screen tearing went away completely. Whatever is causing the screen tearing is making my mouse input wank causing it to get all jerky, which I originally thought was just in my head. Mouse input feels much smoother and accurate when in windowed versus fullscreen for me right now, was able to test this in a server with PixelTerrorist.

I don't know if this has anything to do with using 2 monitors or that I have an SLI setup or something, but it's kinda making it hard to play, as windowed is hard for me to play in especially with my current setup. I'd really rather not use vsync, which does remove the tearing, since it usually causes input lag. If I have the FPS locked at 120, which should fix the problem as it does in most games, I still get the screen tearing. I even used DXTory to force-lock the FPS at 120 and not 125 which is what the in-game lock sticks to (even using com_maxfps 120 it still went to 125) and still no dice.

​Use com_maxfps 300, disable your second monitor (by pressing Windows key + P) and remove your external fps locks. See if you notice any difference in fullscreen.

Share this post


Link to post
Share on other sites

That external FPS lock is just going to make everything worse. Your input is bound to your framerate, so the higher your framerate the lower your input lag will be. Screen tearing will be reduced as well. com_maxfps caps the framerate only at 1000/int values, that's why com_maxfps 120 locks you at 125.

Share this post


Link to post
Share on other sites

It didn't seem to matter what I set the FPS lock to, though. I tried 500 and above and it was the same thing, though I don't get more than 500 consistently so that's kind of pointless. That was the whole reason I tested with an external lock. I'll try disabling the second monitor to see if that helps. Edit: Screen tearing typically happens when you're producing more FPS than your monitor's refresh rate as your monitor can only show as many frames as it's refresh rate can produce, that's the whole point of vsync. So for the record that's why I tried locking it at 120fps. Edit 2: Also, this problem only came along some time after 0.36.

Edited by Viscerated

Share this post


Link to post
Share on other sites

Monitor: Asus VG236H 120hz

GPU: EVGA GTX 690

CPU: i7 3770

RAM: 12GB Patriot 1333

Mouse: Logitech g303

Those are the main relevant specs I can think of.

Also, like I said, this problem ONLY happens in fullscreen with vsync disable. Windowed is completely fine and vsync does make it smoother, I just don't really want to have to use vsync when it seems like a bug as no other game has this issue for me, vsync is just too iffy. It just doesn't seem to make sense considering it was perfectly fine before and all of a sudden it's doing this. Pre-0.36 I never had any issue, and I don't know if it was caused by a change in 0.36.4 but I have a feeling it might be because that's about when my game started feeling weird and I actually noticed it.

Share this post


Link to post
Share on other sites

As an update, I spent the entirety of Friday during the day dueling my friend who had just gotten back into the game. I just checked my Skype to see if this in fact occurred pre-0.36.4 and yes, the dueling was before the patch. At that point, I didn't seem to have any issue, it wasn't until like Saturday after 0.36.4 came out that I was doing racemaps all day feeling like my mouse movement was weird. At one point I happened to be in windowed and even mentioned to Pixel on steam that it felt like I could move more consistently on the Talos map when I was in windowed mode, but brushed it off as just a coincidence. It wasn't until I actually noticed that tearing last night that I tested it and found that windowed mode does feel smoother and plays better than fullscreen for me.

It doesn't feel like I have a hardware issue, it feels like something changed with 0.36.4 that is making my game play weirdly in fullscreen. Which wouldn't be too far out there considering the patch had a lot to do with fullscreen and windowed mode, can't rule out that something didn't break with the fixes (as tends to happen with most things in the world). Messing around with Pixel on his server while mapping I was able to land shots significantly more consistently and move more consistently in windowed than fullscreen. Regardless of what my FPS cap was set to.

Share this post


Link to post
Share on other sites

Here's a video I recorded showing what happens when I switch from a windowed resolution preset under 1920x1080 (i.e. 1680x1500) to either 1920x1080 or a custom res like 1920x1050. The choppiness that happens is the same that happens when I switch to fullscreen,

https://www.youtube.com/watch?v=H9mlES3FFFg

 

OBS causes some minor stuttering in general on the video, but if you play in 720p60FPS or if it becomes available 1080p60FPS you should be able to see the huge difference in smoothness between when I go from 1680x1050 to 1920x1050 and then back to 1680x1050. This was recorded after disabling the 2nd GPU in my 690. I just want to play like I could before. :( 

Edit: Also wanna mention I'm on Windows 10.

 

Edited by Viscerated
OS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×