Jump to content
mmm

Constant stutters during gameplay

Recommended Posts

I've had this problem for at least half a year now, since 0.34 I think, I don't even remember anymore. It was working fine one version than boom, no more playing. I check back every version now and then but it's still not fixed.

Not only the game stutters, it freezes up the whole system. If I alt-tab, I start to get crazy 5 second system hangups with CPU usage climbing to the top on all 8 cores.

Tried it fullscreen, windowed, any video settings starting from the lowest, vsync on/off, com_maxfps, doesn't do anything, "map empty" has the same problem. I also noticed how after each large hangup the console says "server stall, skipping gamestates to catch up". Starting from the .exe directly like it was suggested in the other thread, also doesn't help.

Win7 x64, FX-8320, GTX750Ti

Share this post


Link to post
Share on other sites
48 minutes ago, mmm said:

I've had this problem for at least half a year now, since 0.34 I think, I don't even remember anymore. It was working fine one version than boom, no more playing. I check back every version now and then but it's still not fixed.

Not only the game stutters, it freezes up the whole system. If I alt-tab, I start to get crazy 5 second system hangups with CPU usage climbing to the top on all 8 cores.

Tried it fullscreen, windowed, any video settings starting from the lowest, vsync on/off, com_maxfps, doesn't do anything, "map empty" has the same problem. I also noticed how after each large hangup the console says "server stall, skipping gamestates to catch up". Starting from the .exe directly like it was suggested in the other thread, also doesn't help.

Win7 x64, FX-8320, GTX750Ti

Just a couple thoughts:

  • Is your video driver up-to-date?
  • Do you have some anti-virus that's trying to "active scan" Reflex in real-time or something? 
  • Do you get the same results with a fresh config?
  • Do you have a bunch of widgets installed? (Maybe try deleting them any custom widgets and seeing if that helps.)

Share this post


Link to post
Share on other sites
13 minutes ago, lolograde said:

Just a couple thoughts:

  • Is your video driver up-to-date?
  • Do you have some anti-virus that's trying to "active scan" Reflex in real-time or something? 
  • Do you get the same results with a fresh config?
  • Do you have a bunch of widgets installed? (Maybe try deleting them any custom widgets and seeing if that helps.)

Video driver is not the latest but updated fairly recently and the problems started quite a few driver updates earlier.

I have AVG but it doesn't do anything like that, at least not in any other game.

I deleted the game.cfg (if that's enough) and the game is now 720p in windowed mode and that didn't help.

The only widgets I have are from the reflexrun pack. They were disabled but I moved them into a different folder for the sake of testing. Also didn't help.

Share this post


Link to post
Share on other sites
Just now, mmm said:

Video driver is not the latest but updated fairly recently and the problems started quite a few driver updates earlier.

I have AVG but it doesn't do anything like that, at least not in any other game.

I deleted the game.cfg (if that's enough) and the game is now 720p in windowed mode and that didn't help.

The only widgets I have are from the reflexrun pack. They were disabled but I moved them into a different folder for the sake of testing. Also didn't help.

Unless it's a pain or you know it'll cause issues, I'd say go ahead and update drivers to be sure.

That was the only config, correct? Reflex could be loading another config.

Someone can correct me if I'm wrong, but I think disabling widgets doesn't stop them from loading stuff. I've experienced a few widgets that caused performance hits simply by being installed. I'd say try getting rid of reflexrun entirely from the Reflex folders (move to desktop or something) and make sure that's not it. 

Those are my only suggestions. If they don't help, hopefully someone else will be able to help you out.

 

Share this post


Link to post
Share on other sites
24 minutes ago, mmm said:

Well, it wasn't that in my case. Now reflexrun widgets are not in the widget list and that didn't do anything.

To be sure, you completely removed the reflexrun widgets from any folder in the Reflex directory? Sometimes just moving them one folder over could still cause them to be loaded. I'd remove them entirely too be sure.

Share this post


Link to post
Share on other sites

Oh my god, I've finally thought about the thing I should've tried ages ago - setting core affinity to use a single core fixes the problem! The only annoyance is that I have to set it every time I run the game so maybe the developers could make some kinda fix.

Share this post


Link to post
Share on other sites

This doesnt seems like issue with game but more like problem on your side. I know memphis play Reflex just fine with Fx8350 which is sligtly better than your cpu. Try google some fixes, there is many threads for amd, or unpark cpu.. Though performance dropped  couple versions ago...

Share this post


Link to post
Share on other sites

Well, I only recall core affinity thing affecting one game, don't remember which one, though, was quite a few years ago on a quad-core AMD. Had to use IceAffinity program which I still have.

Share this post


Link to post
Share on other sites

Sorry for resurrecting an old thread but it might be of use to some people. I've found the culprit by accident through the similar bug with another game. The issue is related to something called core parking and it's a known issue for some games on machines with Win7 + FX and Bulldozer processors that requires hotfixes. The thread I've found suggests installing two hotfixes in order:

https://support.microsoft.com/en-us/kb/2645594

https://support.microsoft.com/en-us/kb/2646060

The problem with that game and, coincidentally, Reflex was fixed for me by installing the first hotfix. Now the stuttering and Alt-Tab hangups are finally gone.

Share this post


Link to post
Share on other sites

This is most likely unreated but the first time I shoot rockets or use the IC gun the game stutters for like a second before going back to normal. It only happens the first time I shoot and not always.

This is on a i7-4790k with 32gb RAM and Gtx 980 graphics card, and windows 10.

Share this post


Link to post
Share on other sites
On 13/12/2016 at 8:00 AM, mmm said:

Sorry for resurrecting an old thread but it might be of use to some people. I've found the culprit by accident through the similar bug with another game. The issue is related to something called core parking and it's a known issue for some games on machines with Win7 + FX and Bulldozer processors that requires hotfixes. The thread I've found suggests installing two hotfixes in order:

https://support.microsoft.com/en-us/kb/2645594

https://support.microsoft.com/en-us/kb/2646060

The problem with that game and, coincidentally, Reflex was fixed for me by installing the first hotfix. Now the stuttering and Alt-Tab hangups are finally gone.

Glad you got it fixed, and thanks for coming back to post how you solved it :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×